При обновлении ISPConfig вылетела ошибка не позволяющая обновить mysql. Для решения проблемы в файле /etc/mysql/my.cnf после [mysqld] добавил:

sql-mode="NO_ENGINE_SUBSTITUTION"

И перезапустил:

service mysql restart

 После этого обновление панели прошло успешно.

Продолжая работать над оптимизацией своего домашнего сервера и сайтов я решил заменить MySQL на MariaDB. Почему на марию и что это вообще такое объяснять не вижу смысла. Это всё легко ищется в гугле. Главное что мария увеличивает скорость работы баз данных сайтов.

Внимание! При установке MariaDB будет удалён сервер MySQL со всеми зависимостями.

Внимание! Прежде чем приступать к миграции сделайте бэкапы всех своих сайтов!

Команды установки для своего дистрибутива можно взять на сайте MariaDB.

 В моём случае это команды для Debian 7 "Wheezy". Сначала установить пакет для управления используемыми APT-репозиториями:

apt-get install python-software-properties

Далее получить ключи:

apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0xcbcb082a1bb943db

Подключим новый репозиторий:

add-apt-repository 'deb [arch=amd64,i386] http://mirror.timeweb.ru/mariadb/repo/10.1/debian wheezy main'

Обновим информацию о доступных пакетах:

Установка PHP 7.0.5 на Debian 7 с панелью ISPConfig 3

Для существенного ускорения сайтов на своём сервере я установил новый PHP 7.0.5 Мануал по которому собирал был для Debian 8 но по нему получилось поставить и на Debian 7. При конфигурировании PHP потянул много зависимостей.

Итак инструкция по которой ставил. Загрузка и извлечение из архива PHP 7 из Github:

mkdir -p /opt/php-7.0.5
mkdir /usr/local/src/php5-build
cd /usr/local/src/php5-build
wget http://de1.php.net/get/php-7.0.5.tar.bz2/from/this/mirror -O php-7.0.5.tar.bz2
tar jxf php-7.0.5.tar.bz2

Переходим в директорию php-7.0.5:

cd php-7.0.5/

 Установка пакетов для сборки PHP 7:

apt-get install build-essential
apt-get install libfcgi-dev libfcgi0ldbl libjpeg62-turbo-dbg libmcrypt-dev libssl-dev libc-client2007e libc-client2007e-dev libxml2-dev libbz2-dev libcurl4-openssl-dev libjpeg-dev libpng12-dev libfreetype6-dev libkrb5-dev libpq-dev libxml2-dev libxslt1-dev
ln -s /usr/lib/libc-client.a /usr/lib/x86_64-linux-gnu/libc-client.a

Вышла бэта версия хостинг панели ISPConfig 3.1. Вот перечень изменений:

  • Новый отзывчивый интерфейс на основе Bootstrap. Интерфейс построент на аяксе, что делает его простым в использовании на мобильных устройствах.
  • Цифровая подпись электронных писем с DKIM теперь интегрирована.
  • Поддержка DNSSEC
  • Создание бесплатных SSL- сертификатов непосредственно из ISPConfig.
  • Управление XMPP серверами в ISPConfig.
  • Поддержка HHVM (Hiphop Virtual Machine), как PHP.
  • Полная поддержка PHP 7.
  • Поддержка Ubuntu 16.04.
  • Новый REST API.
  • Поддержка нескольких серверов по умолчанию каждого клиента на нескольких установках сервера.

Поддерживаемые дистрибутивы Linux

  • Debian Etch (4.0) – Jessie (8.0) and Debian testing
  • Ubuntu 7.10 – 16.04
  • OpenSuSE 11 – 13.2
  • CentOS 5.2 – 8
  • Fedora 9 – 15

Коммерческая версия конструктора контента JBZoo не будет работать если на вашем сервере не установлен ionCube

Для его установки необходимо перейти в папку /usr/local/src и скачать в неё архив со скриптом установщиком. Версию нужно выбирать исходя из разрядности операционной системы. В моём случае это 64 битная  ось Debian 7. Для установки я выполнил команды (под учётной записью root):

cd /usr/local/src
wget http://downloads3.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.tar.gz

Далее распаковал данный архив:

tar -xvf ioncube_loaders_lin_x86-64.tar.gz

В куче распакованных файлов есть библиотеки всех поддерживаемых версий PHP, необходимо выбрать ту версию которую вы используете. У меня был установлен PHP 5.4, поэтому я выбрал соответствующие файлы. Кстати проверить текущую версию PHP можно выполнив команду:

php -v

Ответ моего сервера был: PHP 5.4.35-0+deb7u2 (cli) (built: Nov 19 2014 07:56:24)

cooltext1694902455.png